安装Elementor Pro插件后提示PHP Warning: Undefined array key “requires” 错误的解决办法

最近搬主题听到一些小伙伴在安装Elementor Pro插件【Elementor Pro 3.8.1+Elementor 3.8.0完美汉化中文版(含全套模板)|可视化编辑页面自定义设计WordPress插件】后,发现WordPress后台提示一些错误,如下:

PHP message: PHP Warning: Undefined array key "requires" in /var/www/www.banzhuti.com/wp-content/plugins/elementor-pro/license/updater.php on line 69
PHP message: PHP Warning: Undefined array key "new_version" in /var/www/www.banzhuti.com/wp-content/plugins/elementor-pro/license/updater.php on line 84
安装Elementor Pro插件后提示PHP Warning: Undefined array key “requires” 错误的解决办法插图

如何解决这些问题呢?

搬主题就分享一下两个解决办法。

1、降级到PHP 7.4

一般出现这种问题的话都是PHP 8与Elementor Pro插件不兼容导致,也就是一些PHP语言在PHP 7.4是正常使用的,到PHP 8版本后不兼容了,会提示错误,一般解决这种问题的方法就是将PHP 8降级成PHP 7.4即可。

2、删除错误代码

对于不想降级PHP 8版本的小伙伴,可以选择第二种方法,也就是删除代码的方法。

首先打开插件下的文件updater.php,一般路径都会在/elementor-pro/license/updater.php

然后删除69到71行的如下代码:

        if ( version_compare( $wp_version, $version_info['requires'], '<' ) ) {
            return $_transient_data;
        }

再删除83到90行的如下代码:

        if ( version_compare( $this->plugin_version, $version_info['new_version'], '<' ) ) {
            $_transient_data->response[ $this->plugin_name ] = $plugin_info;
            $_transient_data->checked[ $this->plugin_name ] = $version_info['new_version'];
        } else {
            $_transient_data->no_update[ $this->plugin_name ] = $plugin_info;
            $_transient_data->checked[ $this->plugin_name ] = $this->plugin_version;
        }

然后保存文件,接下来刷新页面,重启PHP就行了,无需降级到PHP 7.4。以上就是搬主题分享的安装Elementor Pro插件后提示PHP Warning: Undefined array key "requires" 错误的解决办法。

来源:安装Elementor Pro插件后提示PHP Warning: Undefined array key “requires” 错误的解决办法

 收藏 (0) 更新不易,打赏吧

您可以选择一种方式赞助本站

支付宝扫一扫赞助

微信钱包扫描赞助

除特别注明外,本站所有文章均基于CC-BY-NC-SA 4.0原创,转载请注明出处。
文章名称:《安装Elementor Pro插件后提示PHP Warning: Undefined array key “requires” 错误的解决办法》
文章链接:https://www.xiapilu.com/web/web-tutorial/elementor-pro-php-warning-undefined-array-key-requires.html
分享到: 生成海报

热门文章

评论 抢沙发

评论前必须登录!

立即登录   注册

切换注册

登录

点击按钮进行验证

忘记密码 ?

切换登录

注册

我们将发送一封验证邮件至你的邮箱, 请正确填写以完成账号注册和激活

点击按钮进行验证